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EAGLE 4.13 tutorial 

DEEL 1 : INLEIDING 

 

 

In deze tutorial gaan we een PCB (Printed Circuit Board = gedrukte schakeling, kortweg: 

print) ontwerpen voor een relatief eenvoudige elektronische schakeling: een "knipperLED". 

Hierbij zullen we gebruik maken van het Eagle software pakket. Het is de bedoeling van deze 

tutorial om u op een gestructureerde wijze door de hoofdlijnen van dit pakket te leiden. 

Eens u deze tutorial doorlopen heeft, zal u de basisvaardigheden onder de knie hebben om ook 

een groter project tot een goed einde te brengen. 

 

U kan de freeware-versie Eagle Light downloaden van http://www.cadsoft.de/freeware.htm 

Met deze versie kan u maximaal een dubbelzijdige PCB van 100x80mm realiseren. 

De KHLim beschikt over een professionele licentie, waarmee maximaal een 16-laagse print 

van 1,6m x 1,6m kan gerealiseerd worden - met overigens volledig dezelfde software. 

 

Een project start met het tekenen van een elektronisch schema met behulp van de Eagle 

Schematic Editor, om van daaruit door te gaan naar het ontwerpen en ‘routen’ van de 

printplaat zelf met de Eagle PCB Layout Editor. 

 

1.1   Start het programma 
 

1. Start de computer op. 

 Het besturingsprogramma Windows 2000 wordt automatisch gestart. 

2. Log in met uw persoonlijk studentenaccount. 

3. Start het Eagle 4.13 programma op via 

  Start > KHLim > Eagle > Eagle 4.13. 

 

Hierna verschijnt het Control Panel venster. 

Maximaliseer eventueel dit venster door <L> te klikken op het witte vierkantje 1 in de 

rechter-bovenhoek van het venster. 
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1.2   Creëer een nieuw project 
 

Een handige manier om ervoor te zorgen dat alle gecreëerde bestanden in een behoorlijke 

directory-structuur worden opgeslagen, is gebruik maken van een zogenaamd 'project'. Door 

het opgeven van een projectnaam, geeft u ook een subdirectory aan waarin alle gegevens 

zullen gestockeerd worden.  

 

1. Tijdens deze zittingen zal u uw projecten steeds opslaan in de subdirectory eagproj (= 

afkorting voor Eagle projecten) op uw persoonlijke netwerk-drive H: 

 Selecteer daarom in de menubalk bovenaan in het Control Panel venster 

  Options > Directories... 

2. Wijzig in het (laatste) vakje Projects de default waarde $EAGLEDIR/projects naar 

  H:\eagproj 
 Als deze directory niet bestaat, vraagt Eagle of hij mag aangemaakt worden - klik Yes. 

3. Nu kunnen we een nieuw project gaan beginnen: 

  File > New > Project  

4. In het Control Panel verschijnt onder het item Projects de (automatisch voorgestelde) 

naam voor een nieuw project New_Project_1. 

 Wijzig deze naam in knipperLED. 

 

Vervolgens gaan we in dit project een schema aanmaken. 

5. Er moet een groen lichtje oplichten achter de naam knipperLED, om aan te geven dat dit 

project momenteel geselecteerd is. Indien dit niet het geval is, klik dan <L> op het grijze 

puntje achter de projectnaam; hierdoor moet het groene lichtje gaan branden. 

6. Selecteer File > New > Schematic. Hierdoor zal de Schematic Editor openen. 

 

7. In de menubalk bovenaan in dit schematic window selecteren we File > Save as... en 

kiezen dan led.sch als naam en klikken <L> op de knop Opslaan. 
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EAGLE 4.13 tutorial 

DEEL 2 : SCHEMATIC EDITOR 

 

 

Meestal begint het ontwerpproces voor een elektrisch/elektronisch systeem met het opstellen 

van een schema. De schematic editor van het Eagle pakket stelt de gebruiker in staat zich een 

visueel beeld te vormen van het systeem dat men aan het ontwerpen is. 

Dit deel van deze tutorial zal u helpen om het schema op te stellen voor onze "knipperLED". 

Aan de hand van deze informatie kan u dan later uw eigen projecten gaan uittekenen. 

 

2.1   Plaats de componenten op het schema 
 

De componenten die op een schema geplaatst worden, zijn afkomstig uit bibliotheken of 

libraries. Elke component in een bibliotheek bestaat enerzijds uit een symbool voor gebruik 

op het elektronisch schema, en anderzijds uit een behuizing voor gebruik op de PCB-layout 

(vaak aangeduid als footprint; meestal hebben we de keuze uit meerdere behuizingen voor 

hetzelfde symbool). 

Onderstaande figuur toont bij wijze van voorbeeld de LM555 timer-IC in een DIP8-behuizing, 

zoals deze terug te vinden is in de "linear" bibliotheek (verder in de tekst zullen we zelf 

hiernaar op zoek gaan). 

 

Bij het Eagle pakket wordt een behoorlijk aantal bibliotheken meegeleverd, waarin een groot 

aantal componenten is ondergebracht. Toch kan het nog altijd voorkomen dat een component 

die wij net nodig hebben, in geen enkele bibliotheek terug te vinden is. Je kan dan bv. op het 

internet op zoek gaan naar een bibliotheek die deze component wel bevat, of je kan de 

component zelf gaan aanmaken in een eigen bibliotheek (of bijvoegen in een reeds bestaande 

bibliotheek). In het vierde deel van deze tutorial zullen we zelf zo'n component gaan creëren. 

Bovendien hebben we in onze Hogeschool reeds zelf een bibliotheek "KHLim" aangemaakt, 

met componenten die we frequent nodig hebben. 

Op de volgende pagina beschrijven we de procedure om een component op een schema te 

plaatsen. 
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2.1.1   Een component uit een standaard bibliotheek op het schema plaatsen 

 

1. In de menubalk bovenaan het schematic editor window kiezen we Edit > Add.... 
 

Een andere mogelijkheid is gebruik maken van de toolbar of werkbalk aan de 

linkerkant van het schematic editor venster. 

 

Wanneer we langzaam met de muis over deze icoontjes bewegen, verschijnt er 

telkens in een geel tekstkadertje de functie van het betreffende symbool. 

 

Indien we zo met de muis boven dit icoontje (Amerikaans 

symbool van AND-poortje, samen met zwart cursor-pijltje) 

komen, zal de tekst Add verschijnen. 

 

 

 

Dit is dus de snelkoppeling met als betekenis : "add component from library". 

 

 

Het blijft om het even welk van de twee mogelijkheden we gebruiken, het resultaat zal zijn dat 

er een nieuw venster verschijnt met een lijst van de beschikbare bibliotheken. 

 
 

2. Typ in het Search kadertje links-onderaan *555* en eindig met <Enter>. 

  

Het * teken hierin heeft de functie van wild card, zodat op zoek gegaan wordt naar alle 

componenten (in alle beschikbare bibliotheken) waarvan in de naam ergens de tekstcombina-

tie 555 voorkomt - ervoor en erachter mag staan wat er wil. 

(Om een nieuw zoek-bevel te starten, wist u het zoekveld volledig en klikt op <Enter>; 

hierdoor zullen de zoek-criteria gereset worden.) 

Er zullen veel componenten getoond worden waarvan ergens in de naam de tekstcombinatie 

555 voorkomt. 

Add 
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3. Beweeg de schuifbalk in het Name-kadertje naar beneden tot de linear bibliotheek 

zichtbaar is. Expandeer vervolgens de "*555" optie door te klikken op het  +kadertje 

ervoor. Als u vervolgens klikt op de LM555D, dan ziet u dat hieraan een SMD-behuizing 

(SO08) gekoppeld is. Klikt u echter op de LM555N, dan zie u de 8-pens DIL-behuizing. 

 Zorg ervoor dat deze LM555N geselecteerd is en klik op OK. 

 

4. Het programma keert terug naar het schematic venster en er hangt nu een ghost-image 

(spookbeeld) van het symbool aan de cursor. Beweeg de cursor naar de gewenste plaats 

op het tekenblad en plaats het symbool door <L> te klikken. 

 Dit symbool wordt nu getekend, en bovendien blijft het ghostbeeld nog steeds aan de 

cursor hangen om eventueel een volgend exemplaar van hetzelfde symbool op het schema 

te plaatsen. 

 Indien u <R> klikt, zal het ghostbeeld 90° ccw (linksom) roteren. Uiteraard kan u dit 

meermaals herhalen (om 180° of 270° linksom te roteren). 

 Een component echt spiegelen kan alleen nadat hij reeds op het schema geplaatst is. 

 

5. We moeten maar één LM555N plaatsen; druk daarom <Esc> op het toetsenbord. 

 Hierdoor komt u terug in het Add Component venster, om eventueel een volgende 

component te selecteren. 

 Druk opnieuw <Esc> op het toetsenbord of klik <L> op Cancel om terug te keren naar 

de schematic editor. 

 

Om het schema van onze knipperLED te vervolledigen, zullen er natuurlijk nog (symbolen 

van) componenten moeten toegevoegd worden. De weerstanden en condensatoren die we gaan 

gebruiken, zullen we ophalen uit onze zelf aangemaakte KHLim bibliotheek, zoals in volgend 

punt beschreven wordt. 

 

2.1.2   Componenten uit de KHLim-bibliotheek op het schema plaatsen 

 

Wanneer we een bibliotheek willen gebruiken die niet tot het 'standaard' pakket van Eagle 

behoort, zullen we deze eerst beschikbaar moeten stellen met het "USE" bevel. 

Bibliotheken moeten steeds de extensie *.lbr hebben. 

Volg onderstaande instructies om de weerstanden en een condensator uit de KHLim 
bibliotheek op het schema te plaatsen. 

 

1. Selecteer Library > Use... uit de menubalk van de schematic editor. 

2. Selecteer Lesinfo op Metis\Data (L:) in het vak Zoeken in: 

3. Kies vervolgens Iwt > DSmets > Eagle413 

4. Selecteer KHLim.lbr en klik Openen (of dubbelklik). 

 

Hierdoor zal deze bibliotheek toegevoegd worden aan de lijst van bruikbare bibliotheken. Om 

een component eruit te gebruiken, volg je nu dezelfde procedure als voorheen beschreven. 

 

5. Zoek de component R4 in KHLim bibliotheek. Plaats drie zulke weerstanden willekeurig 

op het schema; deze weerstanden worden automatisch genummerd als R1, R2 en R3. 

6. Doe hetzelfde voor één condensator CAPP1L, eveneens in de KHLim bibliotheek. 

7.  Zoek en plaats de resterende componenten (uit de Eagle-bibliotheken) op het schema: 

  . 5mm LED - Light Emitting Diode  (Search: LED5MM) 

  . 2-pins connector voor aansluiting van de voedingsspanning (Search: PINHD-1X2)  
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2.1.3   Symbolen voor voedingsspanningen en massa 
 

Op elektronische schema's zullen vaak symbolen geplaatst worden voor massa (0 Volt of 

ground) en voedingsspanningen zoals +5V, +12V en -12V of andere. 

Deze symbolen worden op dezelfde manier op het schema geplaatst als de overige (echte) 

componenten. 

Er zijn meerdere bibliotheken (bv. supply1 en supply2) beschikbaar die symbolen voor deze 

en andere voedingsspanningen bevatten, maar wij raden u aan gebruik te maken van de 

symbolen uit de KHLim-bibliotheek. 

 

Voeg volgende symbolen toe op ons knipperLED-schema: 

4x  GND   (zoek: GND in KHLim-bibliotheek) 

4x  12V supply (zoek:  12V  in KHLim-bibliotheek) 

 

 

2.1.4   Plaats een kader op het tekenblad 

 

Een kader of frame is verplicht op elk schema. Zo'n frame biedt de gebruiker een aantal 

belangrijke inlichtingen, zoals het onderwerp van het schema, de naam van de ontwerper, het 

aantal revisies enz. 

Ook frames worden op dezelfde manier op een schema geplaatst als de overige componenten. 

 

1. Selecteer Edit > Add in de menubalk van de schematic editor. 

2. Zoek naar alle mogelijke kaders door een search uit te voeren naar *frame* 

3. Selecteer KHLim_A4L en plaats het kader op het tekenblad. Druk 2x op <Esc> om terug 

te keren naar de schematic editor. 

 

 

2.1.5   Toevoegen van tekst 

 

Nadat het kader op het blad is getekend, moet er wat tekst toegevoegd worden om voldoende 

informatie over het schema te geven. 

 

1. Selecteer Draw > Text in de menubalk van de schematic editor of klik <L> op het 

overeenstemmende icoontje (Text) in de linkse werkbalk. 

2. Vul de gewenste tekst in: als Auteur geef je je eigen naam en voornaam op. 

3. Klik OK. De tekst blijft nu plakken aan de muis-pointer; beweeg deze naar de juiste plaats 

en plaats daar de tekst door <L> te klikken. 

4. Vul in het vakje Groep de naam van je klas in. 

5. Vul in het vakje Rev de waarde 1.0 in. 
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2.1.6   Wijzig de waarde van componenten 

 

Eén van de laatste stappen om een schema te vervolledigen, is alle componenten voorzien van 

de benodigde namen en waarden. 

 

1. Selecteer Edit > Value in de menubalk van de schematic editor 

 of klik op nevenstaand icoontje (Value) in de werkbalk aan de linkerzijde. 

2. Selecteer de component R3 door de muis te positioneren op het draadkruis 

(crosshair of hot spot) in de component en vervolgens <L> te klikken. Er zal een nieuw 

venster verschijnen dat naar de waarde van deze component vraagt. 

3. Vul de waarde in; voor deze weerstand R3 moet de waarde 470 zijn. 

4. Klik OK. De ingevulde waarde zal hierdoor als tekst verschijnen in het symbool. 

 

Geef nu ook de overige componenten hun juiste waarde: 

• LED :  RED 

• C1 : 10u (= 10 µF) 

• R1 en R2 : 10k (= 10 kΩ) 

 

 

2.1.7   Commando's om de componenten te verplaatsen, roteren of verwijderen 

 

We tonen hier even de werking van het move-bevel om een component te verplaatsen. Het 

rotate-bevel (om te roteren of draaien) en het delete-bevel (om te verwijderen) werken 

gelijkaardig. 

1. Selecteer Edit > Move in de menubalk van de schematic editor. 

2. Plaats de cursor op het draadkruis (hot spot) van de component in kwestie. 

3. Klik éénmaal <L> (voor de Rotate en Delete instructies zal hiermee de gewenste actie 

reeds onmiddellijk worden uitgevoerd) 

4. Sleep het object met de muis naar de gewenste plaats en klik daar opnieuw <L> om het los 

te laten (en dus op die plaats neer te zetten). 

Door gebruik te maken van de Move, Rotate en Delete bevelen moeten de componenten op 

zodanige wijze op het schema geplaatst worden dat de verbindingen ertussen zo overzichtelijk 

mogelijk kunnen gelegd worden. 

Ook voor deze bevelen zijn er icoontjes voorzien in de linkse werkbalk: 

 

Move  Rotate Delete 
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2.1.8   Het GROUP bevel 

 
Het Group bevel is een commando waarmee u heel wat tijd kan besparen. Het wordt altijd 

samen met een ander bevel gebruikt, zoals rotate, move of delete. 

Door eerst een aantal objecten te groeperen, wordt het daarna geselecteerde bevel in één keer 

uitgevoerd op àlle individuele elementen in de groep. 

Hieronder beschrijven we het voorbeeld om een groep van componenten in één keer te 

verplaatsen. 

 

1. Selecteer Edit > Group in de menubalk bovenaan of klik op nevenstaand icoon 

in de linkse werkbalk. 

2. Groepeer de gewenste objecten ofwel door een rechthoek errond te trekken ofwel een 

veelhoek. De geselecteerde objecten zullen daarna oplichten. 

• selectie met een rechthoek : druk <L>↓ en houd ingedrukt terwijl je de muis beweegt 

om de rechthoek te trekken rond de gewenste objecten - laat tenslotte <L>↑ los om het 

groeperen te beëindigen; 

• selectie met een veelhoek : klik <L> (en laat ook weer los) op een eerste punt - 

beweeg de muis en klik opnieuw <L> op een volgend punt - blijf <L> klikken op elk 

gewenst hoekpunt - klik tenslotte <R> om het groeperen met de veelhoek te beëindi-

gen. 

3. Selecteer Edit > Move in de menubalk bovenaan (of op het overeenstemmende icoontje 

links). Uiteraard zou hier het Move-bevel kunnen vervangen worden door een ander bevel. 

4. KLIK EENMAAL <R> op één van de elementen uit de groep om het gekozen bevel uit te 

voeren op de volledige groep. Deze functionaliteit wordt ook beschreven in de statuslijn 

onderaan het toepassingsvenster. 

5. Sleep de groep met de muis naar de nieuwe gewenste locatie en plaats daar neer door 

éénmaal <L> te klikken. 

 

Indien het schema wat wazig is geworden door dit move-bevel, selecteert u View > Redraw 

of u drukt <F2> op het toetsenbord of u klikt <L> op het redraw-icoontje bovenaan.  

 

Pas het schema nu zodanig aan dat u ongeveer onderstaande vorm verkrijgt. 

Het uitlijnen van de 

componenten wordt 

gemakkelijker als u 

eerst het tekenrooster 

(grid) zichtbaar maakt.  

Selecteer hiervoor 

View > Grid... of klik 

op grid-icoontje in de 

tweede rij bovenaan. 

Kies dan deze 

waarden: 
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2.2   Verbind de componenten met NETS 
 

Om pinnen van verschillende componenten met elkaar te verbinden, moeten we gebruik 

maken van het NET commando. 

 

1. Selecteer Draw > Net in de menubalk bovenaan of klik op nevenstaand icoon uit de 

linkse werkbalk. 

2. Plaats de muis-cursor boven één van de aansluitpunten die moeten verbonden 

worden en klik daar <L> (niet ingedrukt houden!). 

3. Sleep het verbindingsnet nu in de richting van het andere aansluitpunt. Als u tussentijds 

van richting wil veranderen, klikt u gewoon <L>, waardoor het hoekpunt wordt vastgezet. 

In principe worden alleen horizontale en verticale lijnen getekend (orthogonaal). 

Indien gewenst, kan u overschakelen op de diagonale tekenmodus, waarbij ook schuine 

lijnen worden getekend. U verkrijgt dit door tussentijds <R> te klikken. 

Links-bovenaan in de menubalk ziet u welke teken-mode er geselecteerd is. 

4. Vervolledig het net nu door <L> te klikken op het andere aansluitpunt. 

5. Indien gewenst, kan u de naam van het net gaan aanpassen. Default hanteert Eagle net-

namen zoals N$1. Wanneer we later de PCB gaan routen, kan het echter handig zijn als een 

verbindingsnet ook een duidelijke, zinvolle naam heeft. 

 Om de netnaam te wijzigen, kiest u Edit > Name uit de menubalk bovenaan of 

klikt u op nevenstaand icoon uit de linkse werkbalk (waarmee ook de namen van 

componenten kunnen aangepast worden). Vul de gewenste naam in in het pop-up venstertje 

en klik OK. 

 Om de nieuwe netnaam nu ook zichtbaar te maken op het schema, selecteert u Draw > 
Label uit de menubalk bovenaan en klikt u vervolgens <L> op het betreffende net. 

Vervolledig nu onderstaand schema. Hierbij nog enkele opmerkingen: 

1. Wanneer er netten worden aangesloten op de power supplies, START DAN EERST OP 

DE POWER SUPPLY ZELF en verbind dan pas met andere aansluitpunten. Hierdoor 

zorgen we ervoor dat de netnamen van de power supplies behouden blijven, wat belangrijk 

is voor de ERC (Electrical Rule Check) achteraf. 

2. Wanneer u een net eindigt op een reeds bestaand net, dan zal er automatisch een 

verbindingspunt of junction worden getekend. 

3. Wanneer twee reeds benoemde netten met elkaar verbonden worden, zal Eagle steeds 

vragen wat nu de resulterende naam moet zijn.  

Gebruik NOOIT het WIRE commando om de elektrische verbindingen tussen pinnen 
van componenten te realiseren - dit MOET met het NET commando gebeuren! 

Wanneer we later de PCB zullen gaan routen, zal Eagle alleen de NET-verbindingen 
gaan aanbrengen!!! 
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UITWEIDING:  NETS en BUSES 
 

In deze uitweiding willen we even het verschil tussen netten en bussen aanhalen. 

Een bus is niets anders dan verschillende netten die visueel gegroepeerd worden in één 

(meestal dikkere) lijn, waardoor het schema overzichtelijker kan worden. 

Zo'n bus is echter alleen maar een tekenelement - de echte elektrische verbindingen kunnen 

alleen gemaakt worden met het NET commando. 

In onderstaand voorbeeldje geven we ter illustratie even de manier van werken met zo'n bus 

aan - het heeft weinig of geen functionele betekenis voor onze knipperLED-schakeling. 

 

1. Plaats twee connectors (zoek: PINHD-1X4) ergens vrij op uw schema. 

2. Creëer de bus. Selecteer Draw > Bus of klik op het icoontje.  

 Teken dan de verticale buslijn - eindig met te dubbelklikken. 

3. Benoem de bus. Een busnaam moet samengesteld zijn uit de namen van al de netten die 

deel uitmaken van de bus. 

 Selecteer Edit > Name (of klik op het icoontje) en klik <L> op de bus.  

 Vul vervolgens als busnaam in : ARRAY[0..2],SINGLES 

  Hierin is ARRAY[0..2] de groepering van ARRAY0, ARRAY1 en ARRAY2 

  SINGLES is gewoon de naam van een enkelvoudig net. 

 Er kan eender welk aantal netten opgesomd worden, de netnamen moeten gewoon 

gescheiden worden door een komma. 

4. Label de bus om de naam van de bus zichtbaar te maken op het schema (Draw > Label). 

5. Verbind de netten aan de bus. Gebruik het NET commando om elke pin van elke 

connector met de bus te verbinden. Start hierbij steeds op de bus zelf. Er zal dan een lijst 

van beschikbare netten verschijnen, u kiest hieruit de gewenste en verbindt deze met de 

juiste pen van de connector. Best takt u elk net van de bus af met een "bus entry", een 

diagonaal lijntje zoals u in de figuur ziet. Gebruik eventueel de rechter-muis-toets <R> om 

over te schakelen tussen orthogonale en diagonale tekenwijze van de netten. 

6. Maak de netnamen zichtbaar. Elk net dat de bus binnenkomt of verlaat heeft een naam. 

Maak met Draw > Label deze naam ook zichtbaar op het schema - de gebruiker moet 

immers kunnen zien welk net waar naartoe gaat. Eagle weet dit reeds (omdat elk net 

automatisch benoemd wordt) en strikt genomen is deze stap dan ook niet verplicht. Het 

schema moet echter ook leesbaar zijn voor de gebruiker! 



 

  
PCB-Ontwerp EAGLE 4.13 Tutorial p.12 

 

2.3   ERC - Electrical Rule Check 
 

Het ERC-commando is een tool dat gebruikt wordt om het schema te controleren op eventuele 

elektrische fouten. 

De ERC zal een lijst met mogelijke fouten en waarschuwingen genereren, maar het is de taak 

van de gebruiker om te beoordelen of dit ook echt elektrische fouten zijn en er dus verbeterin-

gen dienen aangebracht te worden. 

 

Selecteer Tools > Erc in de bovenste menubalk of klik <L> op het ERC-icoontje, 

helemaal onderaan in de linkse werkbalk. 

  

We krijgen volgend resultaat: 

 
De ERROR geeft aan dat de pen CV niet is aangesloten. Meestal is een niet-aangesloten 

ingang inderdaad een fout, maar in dit geval mag deze ingangspen van de LM555 wèl open 

blijven; deze fout mag dus genegeerd worden. 

 

De WARNING geeft aan dat er een naamsverschil voor de voedingsspanning van de LM555. 

In de bibliotheek staat deze voedingsspanning vermeld als V+; wij hebben ze echter aangeslo-

ten op onze eigen voedingsspanning met als naam +12V. 

Uiteraard is dit geen enkel probleem. 

 

 

Zo, ons schema lijkt in orde. We kunnen nu in het volgende deel de overstap maken naar het 

ontwerpen van de PCB-layout. 

 

Vergeet niet uw schema (regelmatig) op te slaan. 
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EAGLE 4.13 tutorial 

DEEL 3 : PCB (Printed Circuit Board) EDITOR 

 

 

Nagenoeg elk modern elektronisch toestel bevat minstens één PCB (Printed Circuit Board, 

kortweg 'print'). Zo'n PCB is (meestal) een glasvezelplaat die gebruikt wordt om enerzijds de 

componenten mechanisch te bevestigen en anderzijds deze componenten onderling op de 

juiste manier te verbinden. Voor deze verbindingen zijn er koperbanen aanwezig op de 

onderzijde (solderside) en eventueel - bij een dubbelzijdige print - ook aan de bovenzijde 

(component side) van de print. 

Binnen het Eagle-pakket is het de Board Layout Editor die ervoor zorgt dat de componenten 

op de PCB geplaatst worden en onderling met koperbaantjes verbonden - in het Engels spreekt 

men van “place and route”. 

 

1. Zorg dat het schema van onze knipperLED geopend is. 

2.  Selecteer in de menubalk van de schematic editor de functie File > Switch to board 

of klik op nevenstaand icoontje in de bovenste werkbalk.  

 

We krijgen nevenstaande waarschuwing 

en door het klikken op Yes zal de Board Layout 

Editor gestart worden. 

 

 

 

Alle componenten van het schema zijn ordeloos geschikt naast een mogelijk PCB-bord.  



 

  
PCB-Ontwerp EAGLE 4.13 Tutorial p.14 

 

Bij nader toekijken merken we de gele 'airwires' die de pinnen van de verschillende 

componenten met elkaar verbinden; dit komt dus overeen met de netten in het schema. 

We zullen nu proberen om de componenten zodanig op het printbord te plaatsen, dat de totale 

lengte van deze 'airwires' minimaal wordt. 

 

 

3.1   Het plaatsen van de 'footprints' 
 

Een footprint (letterlijk: voetafdruk) is een verzameling van pads (aansluitpunten, 

soldeereilandjes) die aangeven hoe een component op de PCB kan bevestigd 

worden. 

Als voorbeeld hebben we reeds de footprint van een 8-pins DIL behuizing gezien. 

 

Om de (footprints van de) componenten op de printplaat te ordenen, zullen we gebruik maken 

van de MOVE en ROTATE commando's die we reeds kennen van bij de schematic editor. 

 

Bij het verplaatsen van een component, zien we de gele airwires (die de verbindingen naar de 

pinnen van de andere componenten weergeven) mee bewegen. Bij een goede componentenop-

stelling zal de lengte van de airwires minimaal zijn; we moeten er dus voor zorgen dat com-

ponenten die onderling verbonden zijn ook dicht bij elkaar geplaatst worden op de print. 

 

Tracht onderstaande componentenopstelling te realiseren. Na het verplaatsen van (een aantal) 

footprints is het soms nodig om het Tools > Ratsnets commando uit te voeren, waardoor de 

airwires zullen hertekend worden.  

In de linkse werkbalk is er ook een icoontje voor deze Ratsnest functie. 

 

Het is belangrijk om steeds zowel schema als board gelijktijdig geopend te hebben 
binnen Eagle. Hierdoor kan er 'annotatie' gebeuren, wat inhoudt dat een wijziging in 
het schema ook automatisch doorgegeven wordt naar het PCBoard (en omgekeerd). 
Wanneer beide files niet samen geopend zijn, kan dit leiden tot inconsistentie tussen 

schema en bord, wat resulteert in een zeer moeilijke controle. 
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We sommen hier nog enkele raadgevingen op, waaraan we aandacht moeten schenken bij het 

realiseren van een componenten-opstelling. 

• Plaats componenten met veel pennen (high pin count components) best in het midden 

van het bord. Zo krijg je meer bordoppervlakte om de verbindingen te realiseren. 

• De (gratis) light-versie van Eagle beperkt de bord-oppervlakte tot maximaal een halve 

Eurokaart, dus tot 100 x 80 mm. 

• Het is belangrijk om montagegaten te voorzien op de printplaat, aangezien deze bijna 

altijd in een behuizing zal moeten bevestigd worden. Uiteraard kunnen op die plaatsen 

geen componenten staan, maar er kunnen ook geen verbindingen lopen! 

• Plaats connectors steeds aan de zijkanten van de print. 

• Componenten moeten minstens 200 mil (5 mm) van de zijkant van het bord verwij-

derd blijven. 

• Gebruik voor het positioneren van onderdelen een vrij grof raster (grid), bv. 100 mil of 

zelfs 500 mil. Hierdoor wordt het gemakkelijker om componenten gealigneerd te krij-

gen. De grid kan dan weer fijner gezet worden om nauwkeurig te kunnen afwerken. 

 

Het instellen van de grid gebeurt met View > Grid... of met het icoontje bovenaan 

links.  

Hierdoor verschijnt een pop-up form, waarin de gewenste waarden worden ingevuld. 

 

 

3.2   Het leggen van de verbindingen 

 

Het 'routen' van het board houdt in dat we de ligging van de koperbanen gaan tekenen, die de 

pinnen van de componenten met elkaar zullen verbinden zoals aangegeven in het schema. 

Ook hiervoor geven we eerst enkele tips. 

 

3.2.1   Routing tips 
 

• Indien een baan van richting verandert, tracht dan de (binnen)hoek steeds groter dan 

90° te houden. Scherpe hoeken neigen er immers naar om conductieve storingen op te 

vangen en vertonen nog andere nadelige hoogfrequente effecten. Gebruik liever twee 

opeenvolgende hoeken van 45° in plaats van één hoek van 90°. Gebruik liever aftak-

kingen in de vorm van een "T" in plaats van een "Y". 

• Om de verbindingen te kunnen leggen, mag je uiteraard gebruik maken van de ruimte 

onder de componenten (IC's, weerstanden, ...). Dit is overduidelijk voor de soldeer-

zijde, maar het kan ook aan de componentzijde gebeuren. 

• Zorg dat je alle afmetingen van de behuizingen en de aansluitpennen kent (databoe-

ken) of kan nameten (schuifmaat, ...). 
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• Indien er meerdere gelijkaardige gepolariseerde componenten (elco's, diodes, maar ook 

IC's, ...) op het bord komen, zorg dan dat deze steeds in dezelfde richting geplaatst 

zijn. 

• De boordiameter van een gat moet minstens 10 mil groter zijn dan de aansluitdraad 

van de component die erdoor moet. 

• Het soldeereiland (pad) moet minstens 15 mil groter zijn dan het geboorde gat. 

• Plaats naam en revisie-nummer van de PCB zowel op soldeer- als op componentzijde. 

• Verbindingen moeten minstens 20 mil (0,5 mm) van de zijkant van de PCB verwijderd 

blijven. 
 
 

3.2.2   Bijzondere richtlijnen voor gefreesde printen 
 

Indien uw print zal gemaakt worden met behulp van de LPKF PCB-freesmachine, houdt u 

zich best aan volgende bijkomende richtlijnen. 

• Ontwerp alleen enkelzijdige PCB's, waarbij er alleen koperbanen zijn op de soldeer-

zijde (onderkant). Omwille van de vereiste nauwkeurigheid kunnen dubbelzijdige 

printen alleen na goedkeuring van de verantwoordelijke technicus. 

• De omtrek van de PCB moet steeds een rechthoek zijn. 

• De standaard-afstand tussen de printbanen is 100 mil (wat gelijk is aan de steek of af-

stand tussen twee pennetjes van een DIL-IC: 100 mil = 0,1" = 2,54 mm). Ga slechts in 

uitzonderlijke gevallen over naar een afstand van 50 mil; dit zal bv. nodig zijn om een 

baantje tussen twee pennetjes van een IC door te leggen. 

• In de lengterichting van een IC (met 0,3" = 300 mil afstand tussen de twee rijen pen-

nen) kunnen op die manier gemakkelijk twee banen lopen. 

• Houd een minimale baanbreedte van 40 mil aan. 

• De minimale clearance of afstand naar een andere baan of pad is 13 mil. Deze clea-

rance kan echter leiden tot soldeerproblemen. De clearance die we verder in deze 

tekst gebruiken, zal resulteren in een gemakkelijker te solderen print. 

• De minimum doormeter van de soldeereilandjes (pads) voor jumpers, vias (doorver-

bindingen van soldeer- naar componentzijde) en componenten is 80 mil. 

• Er wordt slechts een beperkt aantal boordiameters ondersteund: 

o 0,8 mm voor IC's en (kleine) componenten 

o 1,0 mm voor gelijkrichtdiodes, vermogentransistoren, connectoren 

o 3,0 mm voor montagegaten. 

Indien u andere boordiameters nodig heeft, zal u zelf manueel een kleiner geboord gat 

moeten gaan uitboren. 

 
 

3.2.3   Autorouting 
 

Wanneer een PCB wordt geroute, zal men meestal een combinatie van autorouting en manu-

eel routen hanteren. De autorouter kan het merendeel van de airwires/netten snel realiseren, 

maar dan zullen vaak nog enkele speciale of moeilijke netten met de hand moeten bijgelegd 

worden. Bij autorouting zoekt de computer naar mogelijke oplossingen voor het realiseren van 

de verbindingen, waarbij hij zich baseert op een aantal regels die komen uit de DRC (Design 

Rule Check) en uit de Autorouter setup.  Ook al leidt de autorouter niet steeds tot een 100% 

volledige oplossing, toch is het vaak een snel hulpmiddel. 
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Volg nu eerst onderstaande procedure om de DRC zodanig in te stellen dat de resulterende 

PCB conform zal zijn aan de eisen voor gefreesde printen. 

 

1. Selecteer Tools > Drc... uit de bovenste menubalk. Hierdoor zal er een pop-up window 

verschijnen met verschillende configuratie-tabs. 

2. Klik op de Clearance tab.  

 Stel de wire to wire clearance in op 40 mil en de 

wire to pad clearance op 30 mil. 

 Ter informatie wordt er aan de linkerzijde steeds een 

tekening getoond die de betreffende instelling ver-

duidelijkt. 

3. Klik op de Sizes tab. Stel de Minimum Width in op 

40 mil en de Minimum Drill op 32 mil. 

4. Klik op de Restring tab. Stel de Minima voor Pads en Vias in op 80 mil. 

5. Klik op de Shapes tab. Stel de Pads voor Top en Bottom in op As in library. 

6. Klik op de File tab. Klik op de Save as knop, geef een nieuwe filenaam (bv. default2) en 

klik op OK. 

 

De auto-router zal zich nu bij het leggen van de verbindingsbanen gaan houden aan deze 

DRC-instellingen. Indien we slechts een enkelzijdige PCB willen, moeten we dit nog instellen 

in de auto-router zelf. 

 

1. Selecteer Tools > Auto... in de bovenste menubalk van de layout editor of klik <L> 

op nevenstaand icoon in de linkse werkbalk. Ook hier zal er een pop-up venster ver-

schijnen met talrijke instelmogelijkheden.  

2. Klik op de General tab. Zet Top op N/A (not available = niet beschikbaar) en Bottom op * 

(geen voorkeursrichting voor de baantjes). Zet de Routing Grid op 50 mil. 

3. Klik op OK om de autorouter te starten met deze nieuwe instellingen. 

Na enig computer-rekenwerk krijgt u (bijvoorbeeld) onderstaand resultaat. Gemakkelijkheids-

halve vindt u ook schema opnieuw, zodat u eenvoudig kunt controleren. 

 

Het is mogelijk dat de autorouter er niet in slaagt om alle verbindingen te realiseren. In dat 

geval kan u wat aanpassingen aanbrengen in de DRC-configuratie en in de autorouter-setup, 

om daarna een nieuwe poging te ondernemen. Als het echter niet wil lukken, zullen we zelf 

manueel gaan ingrijpen. De manier waarop dit kan gebeuren bespreken we in volgende pun-

ten.  
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3.2.4   Ongedaan maken van de plaatsing van een baan : Ripping up tracks 
 

Het kan soms nodig zijn om een deel van, een volledige, meerdere of zelfs àlle reeds ge-

plaatste printbanen terug te verwijderen. Dit kan nuttig zijn wanneer we met componenten 

beginnen schuiven om een bord te optimaliseren. 

Het bevel wordt geactiveerd met het Edit > Ripup commando uit de bovenste menu-

balk of door <L> te klikken op nevenstaand icoontje in de linkse werkbalk. 

U kan telkens wat uitproberen en daarna terug ongedaan maken door <L> te klikken  

op het undo-pijltje bovenaan. 

 

1. Een individueel segment van een printbaan verwijderen: 

  selecteer Edit > Ripup en klik <L> op het te verwijderen deel van de printbaan. 

2. Een volledig signaal verwijderen: 

selecteer Edit > Ripup en typ de signaalnaam in de command box bovenaan in het 

hoofdvenster. Probeer bv. met GND. 

De naam van een ander willekeurig net kan u steeds te weten komen als u eerst 

<L> klikt op het info-icoontje en vervolgens op de betreffende baan. 

3. Alle signalen behalve enkele verwijderen: 

selecteer Edit > Ripup en typ de signaalnaam in de command box bovenaan in het 

hoofdvenster vooafgegaan door een uitroepteken. Probeer bv. met   ! GND VCC. 

Eerst wordt zichtbaar gemaakt welke signalen zullen verdwijnen; als dit in orde is 

klikt  u <L> op de GO-knop bovenaan (d.i. het verkeerslichtje). 

4. Een groep van segmenten verwijderen: 

selecteer Edit > Group en trek een rechthoek rond de segmenten die u wil verwijderen; 

selecteer Edit > Ripup en klik <R> op één van de te verwijderen segmenten. 

Hierdoor zullen alle segmenten die in de groep zijn opgenomen verdwijnen. 

5. Alle signalen verwijderen: 

selecteer Edit > Ripup en klik onmiddellijk <L> op de GO-knop bovenaan (d.i. 

het verkeerslichtje). Klik Yes voor de bevestiging. 
 

Merk op dat telkens elk verdwenen (segment van een) net opnieuw vervangen wordt door een 

gele airwire, om aan te geven tussen welke punten nog een verbinding dient gelegd te worden. 

Gebruik voor deze operatie dus zeker niet de delete-functie! 

Na elke ripup kan u dan ook opnieuw een autoroute laten doen, of u kan zelf de verbinding 

gaan tekenen zoals we in volgend punt behandelen. 
 

 

3.2.5   Manueel routen 
 

Manueel routen betekent dat we zelf de koperbanen op de print gaan tekenen. Dit is vaak een 

arbeidsintensief werk, maar soms is het onvermijdelijk. Het is namelijk zo dat de autorouter 

geen perfect stuk software is en de zaak soms nodeloos moeilijk maakt. Soms zet de auto-

router zichzelf ook vast, zodat hij omwille van de reeds geplaatste banen de nog resterende 

niet meer kan leggen. In andere gevallen weet de gebruiker zelf beter welk signaal erg kritisch 

is en dus eigenlijk eerst zou moeten geroute worden (en dan ook niet meer herlegd). 

In al deze gevallen zal de ontwerper enkele - of soms zelfs àlle - banen zelf manueel moeten 

aanbrengen. 

Bij wijze van voorbeeld gaan we eerst de verbindingen tussen de twee 4-pins connectoren zelf 

manueel leggen volgens onderstaande figuur. 
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1. Zorg er eerst voor dat er geen echte verbindingen maar alleen nog airwires liggen tussen 

deze twee connectoren - dit gebeurt uiteraard met de ripup-functie. 

 

2. Selecteer Edit > Route of klik op het icoontje.  

3. Hierdoor verschijnt er een werkbalk bij net onder de bovenste menubalk. Hierin kunnen 

alle track-opties ingesteld worden. Selecteer een track-breedte (Width) van 40 mil = 0.04". 

4. Klik <L> op het eerste pad vanwaar u een printbaan wil starten - bv. het tweede pad van de 

bovenste connector JP3. Beweeg de muis recht naar beneden en klik <L> op het eindpad 

om de verbinding te vervolledigen. 

5. Wanneer een airwire helemaal geroute is, zal het ROUTE-

commando automatisch de lijn afbreken om een succesvolle 

verbinding aan te geven. Het ROUTE-commando blijft echter 

actief, en u kan verder gaan met de drie resterende verbindingen. 

Denk er bij het leggen van de verbindingen aan dat u met <R> kan 

overschakelen tussen orthogonaal en diagonaal. Als u <L> klikt 

tijdens het routen, brengt u een hoekpunt aan in de baan. 

 

OPDRACHTEN 
 
1. In de linkerbovenhoek van de printplaat heeft de autorouter een merkwaardige verbinding 

gelegd, waardoor er wel degelijk een te scherpe hoek ontstaan is (linkse figuur).  

 Doe nu eerst een ripup van de twee stukjes baan die de (te scherpe) aansluiting naar pen 8 

van het IC realiseren (middenste figuur).  

 Laat de autorouter tenslotte te ontbrekende verbinding opnieuw realiseren (rechtse figuur). 

 

 

 

2. Doe nu een gelijkaardige handeling, zodat - zoals in nevenstaande 

figuur is weergegeven - de aansluiting van de voedingsspanning 

aan pen 4 van het IC rechtstreeks van de verticale VCC-baan 

komt en niet eerst via pen 8 passeert. 

 

 

 

 

 

 

3. Wijzig de verbinding in de rechterbovenhoek zoals hiernaast is 

weergegeven. Gebruik hiervoor (na ripup) de manuele routing met 

een baanbreedte van 40 mil. 
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4. In deze oefening tonen we aan dat het resultaat van de autorouter sterk afhankelijk is van 

reeds geplaatste verbindingen. 

 

Verwijder (ripup) eerst een aantal banen van onze knipperLED, zodat alleen de banen op de 

linkse figuur overblijven. 

 

Teken vervolgens manueel (volgens de rechtse figuur) de verbinding tussen pen 2 en pen 6 

van het IC. Klik opnieuw op Ratsnest om de nog resterende airwires te zien. 

Laat de resterende verbindingen leggen door de autorouter. 

Vergelijk het nieuw verkregen resultaat (linksonder) met het oorspronkelijke (rechtsonder). 

Wijzig tenslotte het verkregen resultaat nog tot onderstaand voorbeeld met manueel routen. 
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3.3   DRC = Design Rule Check 

 

Bij de Schematic Editor hadden we te maken met de ERC = Electrical Rule Check, die een 

controle ging uitvoeren naar eventuele fouten in het elektrisch schema. 

Bij de PCB Layout Editor verschijnt nu de DRC = Design Rule Check. Deze DRC contro-

leert of de ontworpen PCB ook nog steeds in overeenstemming is met de specificaties die 

door de fabrikant zijn opgelegd. In deze tutorial zijn we ervan uitgegaan dat de print zal ge-

freesd worden; we hebben dan ook een aantal specificaties opgegeven die typerend zijn voor 

dit specifieke productieproces. Deze specificaties moeten dan ook nauwkeurig doorgegeven 

worden aan de DRC (zoals we gedaan hebben op p.17). 

Wanneer een ontwerp afgewerkt is – met autorouting of met manueel routen of met een com-

binatie van beide – moet de DRC-controle uitgevoerd worden en hierbij mogen er geen fouten 

of waarschuwingen overblijven. 

 

U kan ook steeds volgende eenvoudige bijkomende controle op uw ontwerp uitvoeren. 

Selecteer View > Display/hide layers … in de bovenste menubalk of klik <L> op 

nevenstaand icoontje in de linkse werkbalk. 

 

In de pop-up form die nu verschijnt kan u selecte-

ren welke onderdelen u precies wil zien. 

 

Klik eerst <L> op None, waardoor er niets meer 

zou weergegeven worden. 

 

Scroll vervolgens een beetje naar beneden, tot u 

<L> kan klikken op het cijfer 19. Layer 19 geeft 

blijkbaar alleen de unrouted nets weer. 

 

Klik tenslotte <L> op OK. 

 

Terug in de PCB Layout Editor mag nu niets te 

zien zijn, dit is tenminste zo indien alle netten ook 

keurig geroute zijn. 
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EAGLE 4.13 tutorial 

DEEL 4 : LIBRARY EDITOR 

 

 

Het zal frequent voorkomen dat u een speciale component in uw schema moet gaan gebruiken 

die niet standaard in de Eagle-bibliotheken aanwezig is. U zal dan een van volgende acties 

moeten ondernemen: 

1. Ga op het Internet op zoek naar een bruikbare bibliotheek die de component wel bevat. 

 Zoek bv. eerst bij de software-producent zelf op http://www.cadsoft.de/download.htm 

onder de rubriek libraries, waar ook gebruikers hun nieuwe bibliotheken beschikbaar 

stellen. 

2. U kan een bestaande bibliotheek gaan aanpassen en/of uitbreiden. 

3. U kan zelf een nieuwe bibliotheek aanmaken. 

 

In dit gedeelte van de tutorial beschrijven we hoe u een nieuwe component, footprint en 

schematisch symbool kan creëren in een nieuw aan te maken bibliotheek. We zullen dit bij 

wijze van voorbeeld doen voor een kleine 2-pins connector. 

 

4.1   Creëer bibliotheek en component 
 

Sluit eerst de eventueel nog geopende Schematic Editor en PCB Layout Editor. 

1. In het Control Panel, selecteer in de menubalk bovenaan File > New > Library. 
 Er wordt een library-editor venster geopend. Bewaar dadelijk de nieuwe nog aan te maken 

bibliotheek met File > Save as als “mylib.lbr” in uw eigen directory H:\eagproj. 

2. Selecteer Library > Description… en geef een beschrijving op voor uw nieuwe 

bibliotheek, bv. “Dit is mijn eigen bibliotheek”. 

3. Selecteer Library > Device… in de bovenste menubalk of op nevenstaand icoon. In 

het tekstvak achter New: typt u 2PINTerm, waarna u klikt op OK. Bevestig met Yes. 

4. Selecteer Library > Package… in de bovenste menubalk of op nevenstaand icoon. In 

het tekstvak achter New: typt u 2PINTerm, waarna u klikt op OK. Bevestig met Yes. 

5. Selecteer Library > Symbol… in de bovenste menubalk of op nevenstaand icoon. In 

het tekstvak achter New: typt u 2PINTerm, waarna u klikt op OK. Bevestig met Yes. 

 

Een library bestand (*.lbr) in Eagle is op zijn beurt weer samengesteld uit verschillende 

andere files. Zo heeft bv. ieder device dat in een bibliotheek zit zijn eigen device-file (*.dev). 

Gelijkaardig zal er ook voor elke package en elk symbol een aparte file zijn (*.pac en *.sym). 

 

Belangrijk om te onthouden: 
 
Elk device (of component) is de 

combinatie van een symbol (zoals het 

op een schema zal geplaatst worden) 

en een (of meerdere mogelijke) 

package (behuizing, footprint – zoals 

gebruikt op de PCB Layout Editor). 

Library File

*.lbr

Device File

*.dev

Package File

*.pac

Symbol File

*.sym

... meerdere componenten
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6. We gaan nu eerst nevenstaand schema-symbool tekenen. 

 Indien dit niet als laatste bewerking gebeurd is, kiest u 

opnieuw Library > Symbol uit de bovenste menubalk (of met 

het overeenstemmende icoontje bovenaan), u zorgt dat 

2PINTerm oplicht en u klikt OK. 

 

a. Selecteer Draw > Pin uit de bovenste menubalk of klik op nevenstaand 

icoontje helemaal onderaan in de linkse werkbalk.  

 Merk op dat er net onder de bovenste werkbalk een nieuwe werkbalk verschijnt, 

waarmee de properties (eigenschappen) van de pinnen ingesteld kunnen worden.  

 
De vier eerste icoontjes bepalen de oriëntatie van de pin. Default is R0, waardoor de pin aan 

de linkerzijde van het symbool zal komen. De overige mogelijkheden zijn R90 (pin 

onderaan), R180 (pin rechts) en R270 (pin bovenaan). 

Merk op dat tijdens het plaatsen van een pin in de symbol editor ook de functie van de rechter-muis-toets werkt: 

elke <R>-klik doet de pin automatisch 90° ccw draaien. 

 

Met de volgende vier icoontjes wordt de (grafische voorstelling van de) functie van de pin 

gekozen. Default is None, een gewone pin. De andere mogelijkheden zijn: Dot (= inverted), 

Clk (clock) en DotClk (inverted clock).  

 

Met de volgende vier icoontjes wordt de lengte van de pin gekozen. De mogelijkheden zijn 

Point, Short (= 0,1”), Middle (= 0,2”), en Long (= 0,3”). Default staat deze waarde op 

Long, maar wij verkiezen Middle. 

 

Met de laatste vier icoontjes wordt gekozen of de pin en/of pad namen zichtbaar zijn in het 

schema. Mogelijkheden: Off, Pad, Pin en Both. Default staat deze waarde op Both, maar 

wij verkiezen Pin. 

 
Voor Direction is er een pull-down menu met volgende mogelijkheden: 

NC not connected 

In input 

Out output (totem-pole) 

I/O in/output (bidirectional) 

OC open collector or open drain 

Pwr power input pin (Vcc, Gnd, Vss, Vdd, etc.) 

Pas passive (for resistors, capacitors etc.) 

Hiz high impedance output (e.g. 3-state) 

Sup general supply pin (e.g. for ground symbol) 

 

 

Tenslotte kunnen we voor Swaplevel een getal kiezen tussen 0 en 255. Swaplevel=0 betekent dat de pin met geen 

enkele andere kan omgewisseld worden. Als het Swaplevel verschilt van 0, betekent dit dat deze pin kan 

verwisseld worden met een andere pin die hetzelfde swaplevel heeft. 

Bij het aanmaken/wijzigen van een bibliotheek kan vaak heel wat werk gespaard worden 

door het kopiëren van packages en/of symbols uit bestaande bibliotheken. 

Om dit te doen opent u de bestaande library en selecteert de gewenste package of symbol. 

Dan schakelt u alle layers ON, selecteert alles met behulp van het GROUP commando en 

CUT deze informatie. Gebruik tenslotte PASTE in de aan te passen bibliotheek. 
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b. De belangrijkste property is de richting (direction) van de pin, want dit wordt gebruikt 

in de ERC (Electrical Rule Check) en eventueel bij het automatisch aansluiten van de 

voedingsspanningen. 

Voor de pinnen van onze connector stelt u de werkbalk in zoals aangegeven in boven-

staande figuur: R0 – None – Middle – Pin – Direction:Pwr – Swaplevel: 0.  

 

 Voeg dan twee pinnen toe (op één ruitje van 0,1” onder 

elkaar), en klik daarna op het STOP-teken in de bovenste 

werkbalk om te eindigen. 

 

c. Geef elke pin een naam met de functie Edit > Name. Klik 

op de bovenste pin en geef deze de naam POS(+), terwijl 

we de onderste de naam NEG(-) geven. 

 

d. Teken nu de vorm van het symbool, in dit geval een rechthoek rond de pinnen. Selecteer 

de functie Draw > Wire of klik op het overeenstemmende icoon. Teken de vier 

lijnstukken en eindig met <Esc>. 
 

 

 

 

 

 

e. Nu gaan we de twee cirkeltjes bijtekenen aan (het rechteruiteinde van) de pennen. Best 

past u eerst het raster aan: selecteer View > Grid en geef een gridmaat van 0.01 inch op. 

Zoom in tot het nieuwe raster ook zichtbaar is. 

 

Selecteer de functie Draw > Circle of klik op het overeenstemmende icoon. 

We willen een cirkel die ongeveer even groot is als het cirkeltje dat reeds aan het 

linkeruiteinde van de pin staat. 

 Eerst moeten we het middelpunt van de nieuwe 

cirkel aangeven; klik daarom <L> op drie raster-

vakjes rechts naast het einde van de bovenste 

pin. Beweeg vervolgens de muis, waardoor de 

cirkel zal geopend worden. Als deze cirkel aan-

sluit op de pin, klikt u opnieuw <L>. 

 

  

Nu gaan we deze zelf getekende cirkel kopiëren naar de tweede pin. 

 Selecteer de functie Edit > Copy of klik op nevenstaand icoontje. 

 Klik <L> op de reeds geplaatste cirkel, en plaats 

de kopie ervan op de onderste pin. 
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f.  Toevoegen van teksten. Selecteer de functie Draw > Text… of klik op neven-

staand icoontje. Typ de tekst  >NAME  en plaats deze boven het symbool. Plaats 

gelijkaardig de tekst >VALUE onder het symbool. 

 

 

 

 

 

 

 

 

 

 

 Nu moeten deze teksten nog op de juiste ‘layer’ geplaatst worden. 

 Selecteer de functie Edit > Change… > Layer… en klik op het nummer 95, zijnde de 

layer voorbehouden voor Names. Klik vervolgens <L> op (het kruisje net linksonder 

van) de tekst >NAME, waardoor deze verplaatst wordt naar layer 95. 

 Verplaats gelijkaardig de tekst >VALUE naar layer 96. 

 

f. Plaats het centreer-teken. Selecteer de functie View > Mark en plaats het centreer-teken 

ergens in het midden van het nieuwe symbool. Dit zal de ‘hot spot’ zijn van het symbool 

als het op een schema geplaatst wordt. 

 

g. Save! 

 

7. Nadat we in voorgaand punt het symbool opgesteld hebben (= de manier waarop het device 

op een schema zal verschijnen), gaan we nu de footprint of PCB package aanmaken (= de 

manier waarop het device op een PCB zal verschijnen). 

 

a. Selecteer Library > Package… in de bovenste menubalk of met nevenstaand 

icoon. Selecteer 2PINTerm en klik op OK.  

 

b. We gaan nu twee soldeereilanden creëren, in overeenstemming met de aansluitpennen 

van de component en met de voorschriften van de PCB fabricage methode. 

 

 

 

 

We laten het raster op 50 mil staan (veel componenten gebruiken hiervan een veelvoud 

als afstand tussen de pinnen), maar omdat we de boordiameter nu in mm willen opgeven 

moeten we dit ook eerst aanpassen in de grid-setup: 

Selecteer View > Grid... of klik op het overeenstemmende icoontje.  

 

Selecteer in de pull-down menuutjes achter Size en 

Alt de eenheid mm in plaats van inch.  

De waarde zelf hoeft u niet te veranderen, die 

wordt automatisch omgezet.

Bij het creëren van een package, is het aan te raden de concrete component of een 

uitgebreide data-sheet ervan steeds binnen handbereik te hebben, zodat alle nodige 

afmetingen kunnen nagemeten of opgezocht worden. 
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Vervolgens gaan we de pads of soldeereilandjes plaatsen. 

 

Selecteer de functie Draw > Pad of klik op het overeenstemmende icoontje. 

 Er verschijnt bovenaan weer een bijkomende werkbalk. 

 

 Selecteer een rechthoekig pad met automatische diameter en 1 mm boordiameter. 

 Plaats nu twee pads op 0,3 inch (center to center) van elkaar (dit zijn zes vakjes op een 

raster van 0,05”). 

 

c. Geef de pads een naam. Selecteer Edit > Name of klik op het overeenstemmen-

de icoontje. Klik vervolgens op het linkse pad en wijzig de default naam P$1 in 

POS. Klik daarna op het rechtse pad en geef deze de naam NEG.   

 

d. Teken nu de buitenomtrek van de package met het Draw > Wire commando op de Top 

Solder Mask Layer (21 tPlace). Hierbij moet uiteraard rekening gehouden worden met 

de reële afmetingen van de component. 

 

e. Voeg de teksten >NAME en >VALUE bij op de tName en tValue layers respectieve-

lijk. 

 

f. Save! 
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8. In punt 6 hebben we eerst het symbool opgesteld (= de manier waarop het device op een 

schema zal verschijnen), waarna we in punt 7 de footprint of PCB package hebben aange-

maakt (= de manier waarop het device op een PCB zal verschijnen). 

 Nu moeten we het device zelf nog gaan vormen, door zowel het gemaakte symbool als de 

footprint eraan te koppelen. 

 

a. Selecteer Library > Device… in de bovenste menubalk of met nevenstaand icoon. 

Selecteer 2PINTerm en klik op OK.  

b. Selecteer Edit > Add… in de bovenste menubalk. Selecteer 2PINTerm en klik op OK. 

Plaats het symbool in het linkse venster, ter hoogte van het reeds aanwezige centreerte-

ken. Klik op het Stop-teken bovenaan of op <Esc>. 

 

c. Selecteer Edit > Package… in de bovenste 

menubalk.  

 Selecteer 2PINTerm. 

 In het tekstvakje onder Variant name vul je bv. 

300mil in. Klik op OK.  

  

 Indien nodig, kan u op deze plaats meerdere 

mogelijke behuizingen koppelen aan hetzelfde 

symbool.  

 

 

d. Nu moeten we duidelijk gaan maken welke pin van het symbool overeenstemt met welk 

pad van de package. 

 Selecteer Edit > Connect… in de bovenste 

menubalk. 

 Selecteer pin G$1.NEG(-) en pad NEG en klik 

vervolgens op Connect. Hierdoor worden deze 

namen verplaatst naar het rechtse Connection 

kadertje. 

 Pin G$1.POS(+) en pad POS zijn nu reeds 

geselecteerd. Klik op Connect, zodat ook deze 

namen verplaatst worden naar het Connection 

kadertje. 

 

e. Klik op OK. Er komt een groen √ √ √ √ check mark. 

 

f. Klik op de knop Prefix. Vul CONN in in het tekstkadertje. Dit prefix zal gebruikt 

worden bij het automatische benoemen van componenten op een schema en/of PCB. 

Voor weerstanden is dit prefix bv. R, zodat de namen worden R1, R2 enz. Onze eerste 

connector zal nu als naam CONN1 krijgen, de volgende CONN2, ... 

 

g. De component is nu volledig. Save de bibliotheek en sluit de library editor af. 
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4.2 Plaats de nieuwe component op schema en PCB 
 

Open opnieuw het schema van onze knipperLED, waarin we een connector van het type 

PINHD-1X2 uit de pinhead bibliotheek gebruikt hadden. 

Vervang nu deze connector door onze zelf gecreëerde 2PINTerm uit onze eigen mylib 

bibliotheek. Dit moet u nu zonder verdere uitleg tot een goed einde kunnen brengen. 

Vergeet niet dat u eerst de nieuw aangemaakte bibliotheek moet kenbaar maken in het 

tekenpakket (Library > Use)! 

Bewaar het gewijzigde schema. 

 

Open nu terug de PCB layout editor. 

Daarin zal de oude connector verdwenen zijn en in de plaats ervan staat nu onze eigen 

connector naast het bord, met twee airwires die de nog te leggen verbindingen voorstellen. 

Dit is een mooi voorbeeld van de annotation die automatisch gebeurt: een wijziging in het 

schema wordt ook automatisch doorgegeven naar het bord. 

Plaats de connector op het bord, vervolledig de routing (automatisch of manueel) en bewaar 

opnieuw. 
 
 
 

Hiermee eindigt deze initiële kennismaking met Eagle. 
Uiteraard zijn niet alle aspecten en mogelijkheden aan 
bod gekomen, maar die zullen wel naar boven komen als 
u dit pakket wat vaker begint te gebruiken. 
Succes ermee! 
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EAGLE 4.13 tutorial 

DEEL 5 : TIPS & TRICKS 

 

 

In dit gedeelte van de tutorial beschrijven we een aantal handige en/of frequent voorkomende 

operaties met elementen uit de libraries, schematics en boards. 

 

5.1  Power & Ground symbolen 
 

De aansluitingen voor de voedingsspanning (P&G  = Power en Ground) kunnen op het 

schema gewoon met netten getekend worden. In onderstaand voorbeeld wordt een 3-pins 

connector gebruikt voor het aansluiten van de voedingsspanningen op het PCB. 

 

 
 

In een groter schema zal het doortrekken van de P&G-netten vlug onoverzichtelijk worden. 

Daarom wordt meestal gebruik gemaakt van speciale P&G-symbolen. Hierbij weten we dat er 

een fysieke doorverbinding is tussen alle instances van hetzelfde symbool, ook al is dit niet 

uitdrukkelijk getekend. Onderstaand voorbeeld geeft een alternatieve tekenwijze voor 

hetzelfde schema, en zal dan ook tot hetzelfde bord (kunnen) leiden. 

 
Hoe zit dit nu met IC’s? 

 

Als we bv. één of twee NAND-poorten (74LS00) op een schema plaatsen, wordt er geen 

vermelding gemaakt van de vereiste voedingsspanningen voor dit IC. 
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Indien we nu een Erc-controle doen, zullen we volgende foutmelding krijgen: 

ERROR: Sheet 1/1: no SUPPLY for implicit POWER Pin IC1P GND 
ERROR: Sheet 1/1: no SUPPLY for implicit POWER Pin IC1P VCC 

 
Voorzien we nu op het schema bv. een aansluitingsconnector voor de voeding en worden 

hierop de symbolen VCC en GND aangesloten, dan zal deze voedingsspanning ook 

automatisch aangesloten worden op het IC. 

In de library is immers voorzien dat op pen 14 van het IC VCC dient aangesloten te worden en 

op pen 7 GND. Indien deze signalen ergens beschikbaar zijn, zullen ze ook automatisch 

doorverbonden worden. 

 
 

Wanneer we nu het TTL-IC 74LS00 vervangen door een CMOS 4011 (functioneel ook een 

quad 2-input NAND), krijgen we weer een Erc-fout: 

 
ERROR: Sheet 1/1: no SUPPLY for implicit POWER Pin IC1P VSS 
ERROR: Sheet 1/1: no SUPPLY for implicit POWER Pin IC1P VDD 

 

Voor CMOS-IC’s wordt in de library VDD gebruikt voor de positieve voedingsspanning en 

VSS voor de massa. 

Indien we op onze voedingsspanningsconnector het VCC-symbool vervangen door VDD en 

GND door VSS, wordt het probleem weer automatisch opgelost.  
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Een andere oplossing bestaat erin om toch uitdrukkelijk de aansluitingen van voeding en 

massa op het schema te tekenen. Om dit te realiseren dienen we gebruikt te maken van het 

invoke-commando.  

Indien u in de linkse werkbalk op dit icoontje klikt (of u kiest bovenaan Edit > 

Invoke) en u klikt vervolgens met <L> op een van de NAND-poortjes, dan 

verschijnt onderstaand pop-up venstertje waarin het gebruik van het IC wordt vermeld. 

 

Gate A en B zijn niet meer aanklikbaar, omdat deze al in gebruik 

zijn in het schema. Als er nog een volgende NAND2 van de 4011 

zal geplaatst worden, wordt dit normaal automatisch Gate C. 

De P&G-aansluitingen (aangeduid als GATE P en Symbol 

PWRN) worden alleen “On Request” getoond. 

Selecteer deze lijn en klik vervolgens op OK. 

 

 

Hierdoor verschijnen in het schema aansluitklemmen voor de voedingsspanningen VDD en 

VSS van dit IC, die we nu zelf kunnen verbinden met de geschikte connectorpennen. 

   
Dit kan bv. expliciet nodig zijn indien we een CMOS-IC (of een analoog IC) willen aansluiten 

op TTL- (of andere niet overeenstemmende) voedingsspanningen.
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5.2  Net classes 
 

Het is evident dat op een PCB de baanbreedte bepaald wordt door het soort van baan; zo 

zullen de voedings- en massabanen breder moeten zijn dan de signaalbanen. 

Op de board-layout kunnen we eventueel zelf manueel een baan breder of smaller maken. 

We kunnen er echter ook voor zorgen dat het programma automatisch rekening houdt met 

voorop ingestelde baanbreedten voor speciale netten – dit gebeurt met de net classes.  

 

Laten we dit toepassen op een klein voorbeeldje. 

 
Naast één IC 74HC04 gebruiken we vier aansluiteilandjes van het type “wirepad 2.54/1.0” uit 

de bibliotheek wirepad.lbr 

Voor de verbindingen gebruiken we instructie Draw > Net (zeker niet: Wire !!!) 

 
In de opties zien we dat Net class steeds is ingesteld op 0 default. 

 

Indien we hiervan automatisch een board genereren, krijgen we bv. volgend resultaat. 

 
In de DRC stond de baanbreedte ingesteld op 10 mil (DRC > Sizes > Minimum Width) met 

een clearance van 8 mil (wire-to-wire en wire-to-pad).  

Deze 10 mil of 0,25 mm lijkt vooral voor de P&G (Power and Ground) te smal. 

 

Daarom gaan we nu eerst twee klassen bijcreëren: 

- class 1 : voor de massabanen gebruiken we een (print)baanbreedte van 40 mil (d.i. ca. 

1 mm) met een clearance van 15 mil ; 
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- class 2 : voor de voedingsspanning gebruiken we een (print)baanbreedte van 32 mil 

(ca. 0.8 mm) met een clearance van 12 mil . 

Selecteer bovenaan Edit > Net classes... 

 

 
 

Class 0 staat reeds ingevuld als default. Hiervoor zijn geen specifieke waarden ingevuld – het 

programma zal dan de waarden nemen die in de DRC zijn ingesteld. 

Vervolledig nu zelf de waarden voor Class 1 en 2. 

Eindig met OK. 

 

Terug in het schema selecteert u Edit > Change… > Class > 1 gnd en klikt u vervolgens op 

de massa-verbinding. 

Daarna selecteert u Edit > Change… > Class > 2 power en klikt u op de verbinding van de 

voedingsspanning. 

Ter controle kan u steeds op de informatieknop  klikken en dan op het gewenste net. 

 

Keer nu terug naar de board-editor. Hierin is nog niets veranderd. 

Doe eerst een rip-up van alle signalen en laat daarna het board opnieuw autorouten. 

U krijgt dan bv. onderstaand resultaat, waarin de verschillende baanbreedten duidelijk 

zichtbaar zijn. 
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5.3  Pas een bestaande component aan in uw eigen bibliotheek 
 

Stel dat we de component 555N uit de KHLim.lbr willen gaan aanpassen. Deze bibliotheek is 

voor ons read-only; we kunnen dus best eerst de component kopiëren naar onze eigen 

mylib.lbr waar we wel lees/schrijf-rechten hebben. 

 

9. Zorg eerst dat beide bibliotheken beschikbaar zijn. Kies hiervoor in de schematic-editor of 

in de board-editor in de menubalk bovenaan Library > Use en selecteer eerst 

L:(Lesinfo)\IWT\DSmets\Eagle413\KHLim.lbr en vervolgens nog eens Library > Use 

H:\eagproj\ mylib.lbr 

In het Control Panel moeten beide libraries nu zichtbaar zijn. 

 
 

10. Klik in de Schematic Editor bovenaan op Library > Open … en selecteer vervolgens 

mylib.lbr 

11. Om de 555N uit de KHLim-bibliotheek te kopiëren naar mylib, typen we bovenaan in 

het commando-tekstvak de instructie copy 555N@L:\IWT\DSmets\Eagle413\KHLim.lbr 

 
 

 

Hierdoor wordt in een keer 

zowel het device, het symbol als 

de package gekopieerd en deze 

verschijnen in de overeenstem-

mende vensters. Save nu eerst 

opnieuw uw mylib.lbr, zodat 

deze component mee opgeno-

men is. 
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4. Stel dat we de footprint van de DIL8-behuizing wat willen aanpassen. 

Klik daarom om het Package-icoontje bovenaan of selecteer Library > Packa-

ge… en klik vervolgens op DIL8 en tenslotte op OK. 

We krijgen een uitvergroot beeld van de DIL8-package. 

 

Om de juiste informatie te verkrijgen over de gebruikte soldeereilandjes, klikken 

we eerst op het informatieteken en vervolgens op één van de pads. 

 

Het geselcteerde pad 8 heeft een achthoekige vorm 

(Shape = octagon). 

De boordiameter bedraagt 0.032 inch of 32 mil, wat 

overeenkomt met 0,8 mm. 

Het pad zelf heeft een diameter van 0.086 inch of 86 

mil, dus ca. 2,15 mm. 

Deze afmeting is vast, zodat ze op ons board niet kan 

aangepast worden om eventueel een baantje tussen 

twee pennen van een IC door te kunnen krijgen. 

 

We gaan de paddiameter wijzigen naar de waarde auto, zodat de layout-editor rekening 

gaat houden met de ingestelde DRC-rules om de juiste waarde van de paddiameter te 

bepalen. 

 

Klik hiervoor in de linkse werkbalk op het change-icoontje en kies vervolgens 

Diameter > auto. Klik vervolgens op elk van de acht soldeereilandjes, waardoor 

deze beduidend kleiner zullen worden. Save vervolgens. 

In 5.5 zullen we verder ingaan op het effect van deze instelling auto. 
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5.4  Creëer een component met verschillende packages 
 

1. Kopieer eerst de component R4 uit de KHLim.lbr naar uw eigen bibliotheek mylib.lbr 

(zie eventueel vorig punt): 

   Library > Open … mylib.lbr 
   copy R4@L:\IWT\DSmets\Eagle413\KHLim.lbr 

 Deze weerstand van ¼ W heeft op de printplaat normaal een afstand van 400 mil tussen 

de soldeereilandjes; deze package heeft de naam AX4. 

 We willen nu deze component zodanig aanpassen dat we voor deze weerstand de keuze 

hebben of hij op de PCB een lengte van 400, 500 of 600 mil gaat innemen. 

 In de praktijk komt een grotere lengte neer op het verder van elkaar plooien van de 

aansluitdraden; dit kan soms handig kan zijn om een printbaan meer onder de weerstand 

door te laten lopen. 

 

2. Selecteer de package AX4.pac van deze component R4 in uw mylib.lbr en pas 

deze als volgt aan: 

   Pads diameter 0.066 inch 

   Drill diameter 0.04 inch 

3. Save 

4. Trek een group-kader rond de volledige package. Selecteer vervolgens Edit > Cut en 

klik <L> in het center van het linkse pad (om een referentiepunt te hebben) . 

 Ter informatie: in tegenstelling tot de gewone Windows-werking,  zal het Cut bevel hier 

de oorspronkelijke inhoud niet verwijderen. 

5. Creëer een nieuwe package AX5.pac 

6. Selecteer Edit > Paste en plaats de layout met het centrum van het linkse pad gecentreerd 

op het kruisje.  

7. Schuif het rechtse pad nu 100 mil naar rechts en maak het getekende symbool gecentreerd 

en passend tussen beide pads. Save. 

8. Herhaal voor een package AX6.pac met een afstand van 600 mil. Save. 

9. Selecteer opnieuw het device R4. Klik <R> op Package-Variant AX4 “ en selecteer 

Delete > Yes. 

10. Klik <L> op New onder het vakje Package-Variant. Selecteer AX4 als nieuwe package 

en geef _400mil op als variant name. 

11. Doe een connect van deze package variant. 

12. Herhaal: New > AX5 > _500mil > connect 

13. Herhaal: New > AX6 > _600mil > connect 
14. Save 

 

Ga nu naar het schema en plaats daar een weerstand R4 uit mylib.  

U krijgt nu ogenblikkelijk de keuze uit de verschillende variant packages. 

 

Ook wanneer een dergelijke component reeds op het bord geplaatst is, kan u de geselecteerde 

package nog wijzigen met Edit > Change… > Package. 
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5.5  DRC-instellingen voor 1 baantje tussen 2 IC-pootjes 
 

In deze tutorial hebben we reeds een aantal DRC-instellingen besproken. 

We hebben aangehaald hoe we een enkelzijdige print kunnen realiseren. 

Verder hadden we de minimale baanbreedte en clearance zodanig ingesteld dat er geen 

baantjes tussen twee pootjes van een IC door werden gelegd. Dit resulteert uiteraard in de 

veiligste printen, maar vaak zullen we hiermee niet al onze problemen opgelost krijgen. 

 

In de praktijk hebben we vastgesteld dat onze LPKF-freesmachine er geen probleem mee 

heeft om één baantje tussen twee pootjes van een IC door te leggen. 

Om dit mogelijk te maken, moeten we onze DRC-rules gaan verfijnen. 

Laten we eerst alle gewenste waarden in een figuur voorstellen. 

 

steek =

100 mil = 2.54 mm

0.8 mm
boordiameter
(ca. 32 mil)

baanbreedte =
20 mil = 0.5 mm minimaal

clearance =
10 mil = 0.25 mm minimaal

60 mil
pad-diameter
(ca. 1,5 mm)

restring =
14 mil = 0.35 mm

 
 

Om volgens bovenstaande figuur te werken, dienen we in de DRC het volgende in te stellen: 

- DRC > Sizes > Minimum Width = 20 mil (minimale baanbreedte) 

- DRC > Clearance > Wire to Wire, Wire to Pad & Pad to Pad = 10 mil (minimale 

clearance) 

- DRC > Restring > Pads > Top & Bottom > Min > 14 mil 
 

Merk op dat deze restring alleen in rekening wordt genomen indien de afmeting van de 

soldeerpads in de library op auto staat. 

 

U kan misschien best steeds de te gebruiken devices eerst uit de bestaande libraries kopiëren 

naar uw eigen mylib.lbr en dan daarin alle wijzigingen aanbrengen. 

Zo kan u dan bv. de soldeerpads voor DIL14 en DIL8 vast instellen op 60 mil, waardoor de 

restring niet in aanmerking wordt genomen. 
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5.6  Instellingen om een gefreesde print succesvol te kunnen solderen 
 

Op de LPKF-freesmachine moet de diepte van de frees telkenmale manueel ingesteld worden. 

Omdat we meestal zeker voldoende diep wensen te frezen, wordt de frees doorgaans tè diep 

ingesteld. Hierdoor wordt er meer koper weggehaald, waardoor de baanbreedtes en 

soldeereilandjes kleiner worden dan voorzien. Dit leidt achteraf tot veel problemen bij het 

solderen. 

 

Om deze problemen tot een minimum te beperken, kan u best volgende instellingen gebruiken 

voor een te frezen print. 

 

1. Gebruik een minimale 

baanbreedte van 40 mil. Alleen 

indien er bv. tussen twee pootjes 

van een IC moet doorgegaan 

worden, gaat u tijdelijk over op 

een baanbreedte van 20 mil (zie 

ook vorig punt). 

 

 
 
 
 

2. Gebruik steeds (alleszins zo veel mogelijk) een langwerpig pad voor alle soldeereilandjes 

(Change > Shape > Long). 

 Voor gewone weerstanden, condensatoren enz. zorgt u dan best voor een paddiameter van 

minstens 80 mil. 

 Voor IC's  hebben we in vorig punt aangetoond dat er voldoende ruimte is om een baan 

tussen twee pootjes door te leggen indien we een paddiameter van 60 mil gebruiken. 

 

3. Sluit de banen steeds aan in de lengterichting van het 

pad, want daar blijft steeds het grootste kopervlak over 

om op te solderen. 

 

 
 
 
 
 

4. Plaats de soldeereilandjes niet midden in een doorlopende baan, maar vlak ernaast. Zo 

voorkom je dat de boring de baan effectief onderbreekt. 

0.8 mm

boordiameter

(ca. 32 mil)

40 mil = 1.0 mm nominaal

baanbreedte

20 mil = 0.5 mm minimaal

clearance =
10 mil = 0.25 mm

minimaal

60 mil
pad-diameter

(ca. 1,5 mm)
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5.7  Massavlak 
 

Wanneer een printbaan met behulp van de LPKF-freesmachine 

wordt gefreesd, worden eigenlijk de contouren van deze baan 

weggefreesd, om zodoende de baan te isoleren van de rest van 

het koper. 

Op die manier kunnen we echter veel “zwevend koper” 

bekomen, dat nergens mee verbonden is. 

Dit is zeker niet altijd een goede oplossing. 

Daarom wordt er meestal voor geopteerd om zoveel mogelijk 

van het resterend koper met de massa te verbinden, zodat er een 

groot massavlak wordt verkregen. 

 

Hoe moeten we dit op onze board-layout aangeven? 

 

Op het knipperLED-schema van deze tutorial hebben we eerst 4 montage-gaten bij voorzien, 

die met de massa mogen verbonden worden. Vervolgens plaatsen we deze montage-gaten (zie 

bv. library holes) op het board, en passen de omtrek van het board wat aan. 

 

 

 

 

 

 

 

 

 

 

 

Wanneer we nu de autoroute functie uitvoeren, zullen de montage-gaten met de massa 

verbonden worden met een blauwe verbindingslijn. 

Om echter een massavlak te verkrijgen, moeten we een polygon tekenen net buiten 

het kader van de printomtrek. Dit gebeurt met Draw > Polygon of door te klikken op 

nevenstaand icoontje. Eerst klikken we <L> net buiten de linkerbovenhoek van de 

print (niet ingeduwd houden); vervolgens bewegen we de muis en klikken opnieuw <L> net 

buiten de rechterbenedenhoek en tenslotte klikken we nog eens opnieuw <L> op het 

beginpunt, net buiten de linkerbovenhoek. Hierdoor verkrijgen we een blauwe rechthoek net 

buiten de PCB contouren. 

Vervolgens gaan we deze polygon de naam GND geven; hiervoor gebruiken we de 

functie Edit > Name of nevenstaand icoontje. 

 

Als we als Resulting name ook GND aanklikken, 

krijgen we de PCB mèt volledig GND-vlak (resultaat 

is uiteraard nog afhankelijk van ingestelde DRC-

rules). 

 

Die afstand die zal worden vrijgehouden tussen de 

netten en de polygon, wordt ingesteld met de "isolate" 

parameter in de polygon-toolbar. 


